XPI package broken Rated 1 out of 5 stars

I can' install 1.265 with error -228 or -207.
I also downloaded 1.265 xpi but install failed.
bit.ly_preview-1.265-fx.xpi is broken. I can't open this as a zip archive, this is essentially a 404 document of AMO...

This review is for a previous version of the add-on (1.266).