Rated 5 out of 5 stars

Hello your really great add-on don't compatible with Thunderbird 8.0. Update it please. I for myself changed maximum version in zip archive. It works.

I have no problem downloading and installing in Thunderbird 8.0. I'm not sure what you're issue was.