ericrose

About me

Developer Information
Name ericrose
User since March 5, 2007
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

Hola Unblocker

Rated 1 out of 5 stars

Good, but doesn't work with Ffox 30, even the latest version; the icon doesn't show by any means.

Feedly Notifier

Rated 1 out of 5 stars

Good, but doesn't work with Ffox 30; the icon doesn't show.

InstantFox Quick Search

Rated 4 out of 5 stars

Excellent add-on, but the v2.8.2 doesn't work with Nightlies. Could someone please explain where the new v2.8.3 could be downloaded; not found at the add-on's homepage .

This review is for a previous version of the add-on (2.8.2). 

Readability

Rated 4 out of 5 stars

Excellent add-on, but unfortunately doesn't work with Ffox Aurora 20.0a2. Update greatly appreciated.

This review is for a previous version of the add-on (2.4).  This user has a previous review of this add-on.

WikiLook

Rated 4 out of 5 stars

Excellent add-on; regrettably doesn't work with Ffox 20+.

Readability

Rated 4 out of 5 stars

Excellent add-on, but does not work on Ffox 16.0.2, unfortunately.

This review is for a previous version of the add-on (2.4). 

Fire.fm

Rated 5 out of 5 stars

Excellent add-on, at last updated to a working version; the earlier v1.4.14 didn't work with Ffox 16.0.1.

This review is for a previous version of the add-on (1.4.15). 

FootieFox

Rated 5 out of 5 stars

Excellent add-on, but as of this moment, the connection has totally failed, and I'm getting no information. Home page or support not reachable. Please do correct.

This review is for a previous version of the add-on (2.1.13). 

WordReference Translator

Rated 2 out of 5 stars

Excellent add-on but this latest version impossible to install: 'invalid file hash -261'.

This review is for a previous version of the add-on (1.6.3). 

Movie Ratings

Rated 4 out of 5 stars

Excellent add-on. There is however a serious error with Firefox: the newest version 1.5 cannot be installed. An error message appears: Ffox could not install this file, because not a valid install package -207. As I see it, this is not an error of the developer but of Ffox itself, so please correct it as soon as possible. Similar errors have existed several times before, as well.

This review is for a previous version of the add-on (1.5). 

Cluster Tabs for Firefox

Rated 3 out of 5 stars

Otherwise useful add-on, but keeps my Gmail tab continuously reloading, which is annoying.

This review is for a previous version of the add-on (1.1).