Rated 1 out of 5 stars

Stay away. It violates the GPL by incorporating FlashGot 1.1.9 verbatim, and breaks the original FlashGot because it overwrites core components which in the meanwhile have changed.

http://forums.informaction.com/viewtopic.php?f=6&t=1654&p=6378#p6378

This review is for a previous version of the add-on (5.1).