Rated 3 out of 5 stars

This does not work in 3.6.13. The "Works with" versions should be edited to indicate the proper versions. If it doesn't work for you past 3.6.8 (as you said in your description), then you shouldn't set it to be compatible with versions higher than that.