Please support 3.6.6, Chrome, and Safari Rated 5 out of 5 stars

Hello, I am using Firefox 3.6.6 can you please update the extension to work with this version?

Also, would you please create a similar extension for both Chrome and Safari?

I know I'm asking a lot of you, but your work is very valuable and I use it daily. Please consider spending a little time to keep this great add-on up to date. :)

This review is for a previous version of the add-on (3.0.3).