version for 3.6? Rated 5 out of 5 stars

cant seem to get the "3.6" version working that i got from netusage.iau5.com with my firefox 3.6.3 client...would really love this to work for me, any hints? the install works fine but then no tool bar appears for the add on.. any ideas would be great

This review is for a previous version of the add-on (1.2.232).