Rated 5 out of 5 stars

Firefox 3.6 compatible version here: http://netusage.iau5.com/netusagebtn-latest.xpi?r257

You don't need to uninstall the old version.

This review is for a previous version of the add-on (1.2.232).