Rated 4 out of 5 stars

Great, when it worked... Still not working with FF 54.0.1. 'A parsing error occurred (S10)'. Shame to lose this add-on.

E10s support? 55beta1 is out. 54 is production Rated 5 out of 5 stars

E10s will kill this by November 17 if no action is taken. Sad that this should be. Great add-on much needed.

This user has 2 previous reviews of this add-on.

Update Works Occasionally for Me Rated 4 out of 5 stars

Still not working 100% of the time with my Bigpond Account! Using Firefox 53.0.2. It might update correctly once per day but most times it hasn't. Using the April 31st version of the addon.

This review is for a previous version of the add-on (2.0.3). 

Broken In Firefox v53 Rated 5 out of 5 stars

As others have said, Net Usage Item is broken in Firefox v53.

Edit: The beta version is working great.
Thanks.

This review is for a previous version of the add-on (2.0.3). 

Try the beta version

Hi, please try the latest beta version:
https://addons.mozilla.org/firefox/downloads/file/639629/net_usage_item-2.1.2-rc3-fx.xpi

A parsing error occurred (S2) Rated 5 out of 5 stars

Have been getting problem since about February of 2017 eg. "A parsing error occurred (S2)." Just made a donation so I am hoping that this add-on is still going to be useful, especially since Firefox requires every add-on to be signed now?

This review is for a previous version of the add-on (2.0.3). 

Please send the debug information

Thanks for the donation! Could you get the latest version: https://addons.mozilla.org/firefox/downloads/file/639629/net_usage_item-2.1.2-rc3-fx.xpi
then if the parsing error occurs, please go to:
resource://da1b0ab5-7dd3-4066-bc2a-64aabbdd0a8b/data/dev.html
and click 'Send Debug Information'

Great addon Rated 4 out of 5 stars

Was working (Spintel) until 1st Feb 2017, now continual parsing error S5. No netusage_debug.txt file to be found. Used to have the S5 error at the start of every month, but could live with that.

This review is for a previous version of the add-on (2.0.3). 

Re: Lost multiple meters/Rolled back...for multiple Rated 5 out of 5 stars

For those who have lost multiple Net Usage items such as "Lost multiple meters @andpill" and "Rolled back...for multiple @Static" if you navigate to your Net Usage preference page. Look at the address bar and there should be this link (minus the personal info I redacted ) [resource://#hashes#/data/app.html#/item/0] if you change the end from [/item/0] to [/item/1] you will have the second critter again. Also thank you to Ian Bishop for providing the script for my ISP. Cheers

This review is for a previous version of the add-on (2.0.3). 

Accounting is wrong since moving to an iiNet NBN plan (from iiNet adsl) Rated 1 out of 5 stars

New plan starts 22nd of the month, but Netusageitem is rolling over on the 1st. Cleared data, but no change.

No use to me now after many years of service.

This review is for a previous version of the add-on (2.0.3). 

iinet now broken Rated 4 out of 5 stars

New plans seem to have broken this

This review is for a previous version of the add-on (2.0.3). 

iinet limitless broke the parsing. Rated 2 out of 5 stars

iinets usage meter will not parse correctly on the new limitless plans - iiusage can read it jsut fine.

This review is for a previous version of the add-on (2.0.3). 

Rolled back to Ver 1.2.390.1 for multiple, but not working Rated 4 out of 5 stars

Ever since 2.0.2 I have not been able to add multiple ISP's.

Now I get null MB errors

This review is for a previous version of the add-on (2.0.3). 

Lost multiple meters Rated 4 out of 5 stars

Latest update to the addon or firefox seems to have lost the ability to use multiple meters. Was great to be able to keep an eye on both the work and home accounts.

This review is for a previous version of the add-on (2.0.3). 

NZ Slingshot support Rated 5 out of 5 stars

Good little tool.

Needs updating to work with New Zealand SlingShot. change isps_nz.js

'nz.slingshot': {
name: 'Slingshot',
process: [
'GET https://myaccount.slingshot.co.nz/API/?username={USERNAME}&pwd={PASSWORD}',

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Not working with Orcon in NZ Rated 4 out of 5 stars

About 10 days ago the program stopped working with Orcon. All I get is the white cross and ISP error occurred - 404 not found.
Otherwise the program has worked flawlessly for years

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Rated 4 out of 5 stars

Up until recently this add-on has worked like a charm. Unfortunately our ISP (TelstraclearNZ) has changed something and now the definitions need updating. If it weren't for this glitch I'd gladly give 5 stars. I'm hoping someone, somewhere can provide an update.

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Rated 5 out of 5 stars

Have been using this addon for years and it's very good (even doanted once or twice. :) ). Since I swicthed to Telstra NBN a couple of weeks ago it no longer works. My login details are the same as before. Hope you can get this sorted out soon. Thanks for all your work.

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Rated 5 out of 5 stars

Worked perfectly until I switched to NBN in Australia. Clearly, the new system is no longer providing information to the extension. A shame, as it was working perfectly. Here's hoping it can be updated (iPrimus on NBN). 5 stars for excellent, recommended extension/add-on.

This review is for a previous version of the add-on (1.2.337.1.1-signed).  This user has 2 previous reviews of this add-on.

Rated 5 out of 5 stars

Very good work.

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Simply Brilliant! Rated 5 out of 5 stars

KISS.
Unpretentious, simple interface & stable.

One simple click to update a simple, yet very informative, progress widget - 99.9% of the time. If it failed to fetch (rare) just click it again.Can also be configured for auto update.

Developer has since made 4 more themes available. The default is cool but I find the "Classic" easier to read (data - days - %).

Well done!

(Using it for Optus mobile broadband for >2 months)

This review is for a previous version of the add-on (1.2.337.1.1-signed). 

Fantastic Rated 5 out of 5 stars

Love this add on! but unfortunately it doesn't seem to have been working with OptusNet recently.

This review is for a previous version of the add-on (1.2.337.1.1-signed).