Great Add-on; finally broken by Firefox 30 Rated 5 out of 5 stars

I've used this simple, but great, add-on to good purpose for several years now, but it appears finally to have been broken by Firefox 30. Perhaps the developer could rectify this situation if it didn't involve too much work. Very much appreciated.

Abandoned? Rated 3 out of 5 stars

Has this project been abandoned? It reports itself as compatible only through firefox 17.

We shouldn't need an addon for this funcionality Rated 5 out of 5 stars

It's funny it reports itself as incompatible (compatible up to FF10). Still it's indispensable and should be incorporated in FF long time ago.

Rated 5 out of 5 stars

Could you please update the install.rdf to say it works up to FF >=22? It works just fine, but the displayed info is "wrong".

Rated 5 out of 5 stars

Is It Compatible 0.6.0.xpi is compatible with FF 17.0.3 ESR.

I don't understand Mozilla to approve it.

This user has a previous review of this add-on.

4 stars I thought it did nothing but I didn't spot the numbers Rated 4 out of 5 stars

I've installed IIC because the install for FF18 didn't warn me that CacheViewer would be incompatible!

Where's the button though on IIC? because so far IIC has done nothing, hasn't checked anything.

Hold on I see some numbers next to add-ons. You've got to mention this in the add-ons page. Ok now your star rating goes up to 4 stars.

Hey but why does IIC say IIC is only compatible up to FF8!?

Non-Public Interfaces

IIC uses a non-public -- that is, unofficial ;) -- interface to get the compatibility information. This is maintained by Firefox itself. Though the "official" story is that IIC is compatible with up to FF17, the code it ships with says it's compatible with up to FF8. Though this didn't use to be a problem (the source it used took both stories into account), FF may have changed how it reports this info, resulting in the strange compatibility reported.

rTwT Rated 5 out of 5 stars

RT: Should be integrated into Firefox and Thunderbird.

Question? Rated 4 out of 5 stars

When you see this sign " * " behind the version number, what does it mean?

Geek-speak

The asterisk (*) in a common symbol usually meaning "all". In this case, it means "all sub-versions" -- for example, 3.* means all versions that start with 3 (3.0, 3.1, 3.2, 3.6.18, etc). In version numbers, it's a convenient way to specify "all versions greater than or equal to 3.0 and less than 4.0".

Essential Rated 5 out of 5 stars

Should be integrated into Firefox.

Rated 3 out of 5 stars

Firefox: 3.6.18
No harm done; the button appeared; I pressed it, and after some time... nothing happened. On my firefox, compatibility checking is turned off, and there are over a 100 extensions, so maybe that's why nothing happened.

It doesn't disable extensions

Sorry for your troubles, but it wasn't IIC that disabled your extensions. IIC doesn't modify extensions at all; it is, effectively, a read-only extension (it only modifies what is displayed in the addons window). I tried installing it from AMO in a FF3.6.18 install, and it worked perfectly. Could you enable your modified extensions, reinstall IIC, and say if the same thing happens again?

Slow down the opening of addon manager Rated 2 out of 5 stars

If your firefox has many addons installed, its addon manager may freeze up for several seconds before it is ready for interaction.

Rated 5 out of 5 stars

This feature should be part of Firefox by default.

Thanks for amazing work!

Where's the button Rated 4 out of 5 stars

Same problem as others have mentioned about not being able to find the "Show Check Compatibility Button" except I'm on Firefox 6.0.2. Then again nowhere does it even mention where to expect this button.

Though at least it does show the supported version number next to addons in about:addons.

Edit.....
Thanks for the reply from the dev, the button is no longer there to check if addons work with the new version of Firefox, so nothing is actually wrong with the addon. Though it would be great to have that feature back, hint hint.

Only try to realize the truth: there is no button

Sorry for the late response on this. The answer is that this functionality was available in FF3.6 and earlier, but hasn't existed since the FF4.0 changes. The preferences you see are leftovers that were never taken out Sorry for the confusion.

No Button Rated 4 out of 5 stars

Same problem as Neil H.
Where's the button?
Am using FF 7.0.1

Apart from that, it works nicely.

Thanks for the useful add-on

Best regards,

Cha

Rated 3 out of 5 stars

I'm using this with FF7. In "Is It Compatibles" Preferences I have 'Show Check Compatibility Button' ticked, but no such button is visible on my Extensions page...

Rated 5 out of 5 stars

I find this addon to be extremely useful. Unlike the commentators below, I have never had any problems with the addons manager becoming unresponsive. I have 63 addons.

Rated 4 out of 5 stars

Same as user klint mentioned: slows down enormously add-on manager display when many add-ons (60+ here). I'll use it with Thunderbird though (very few extensions). Handy. I still don't understand why displaying add-on compatibilities is not default to Firefox and Thunderbird.

Rated 3 out of 5 stars

Hello
Very useful indeed, thanks.
Just one thing though: I have tens of add-ons and this addon here slows the add-on manager really down. I don't know what it does behind the scene, but I had to uninstall it because of that. Maybe some caching mechanism may help?
Thanks

Rated 5 out of 5 stars

Thank you for enabling upgrading Firefox to be an informed decision!

This review is for a previous version of the add-on (0.5.1). 

Rated 5 out of 5 stars

Wow, ID's are now visible. Waiting for to copy them to clipboard.
Thanks for catching my issue.

This review is for a previous version of the add-on (0.5.1).