4 stars I thought it did nothing but I didn't spot the numbers Rated 4 out of 5 stars

I've installed IIC because the install for FF18 didn't warn me that CacheViewer would be incompatible!

Where's the button though on IIC? because so far IIC has done nothing, hasn't checked anything.

Hold on I see some numbers next to add-ons. You've got to mention this in the add-ons page. Ok now your star rating goes up to 4 stars.

Hey but why does IIC say IIC is only compatible up to FF8!?

Non-Public Interfaces

IIC uses a non-public -- that is, unofficial ;) -- interface to get the compatibility information. This is maintained by Firefox itself. Though the "official" story is that IIC is compatible with up to FF17, the code it ships with says it's compatible with up to FF8. Though this didn't use to be a problem (the source it used took both stories into account), FF may have changed how it reports this info, resulting in the strange compatibility reported.