Seems to work with SeaMonkey 2.35 Rated 5 out of 5 stars

I installed this to SeaMonkey 2.35 and so far it has been working properly. Just click on the "Add to SeaMonkey" and "Install anyway".