Rated 1 out of 5 stars

Please update to TB 5- not compatible !

This review is for a previous version of the add-on (1.6.6).  This user has a previous review of this add-on.