Rated 5 out of 5 stars

"the majority of sites written in English have American spelling, so I'd say go with the American version" This is the golden advice for me because i just need the dict for websites. Many thanks for your help, kuromu :)

This review is for a previous version of the add-on (1.19). 

Rated 4 out of 5 stars

I actually like this add-on, I don't know why people are having difficulties with it - it works fine for me.

Also, for adlercoa421,

Well, the British and American ways of speaking English are different. A lot of words are spelled differently (like center (US) and centre (UK), and color (US) and colour (UK)), the American way is often much more simple than the British way. Neither is better - the spelling is just different. As a British person, I'd love to say choose the British version, but the American spelling of words is simpler and the majority of sites written in English have American spelling, so I'd say go with the American version. Hope that helped.

This review is for a previous version of the add-on (1.19). 

Rated 5 out of 5 stars

Which dict is better? British English Dictionary 1.19 vs. United States English Dictionary 3.0.3 (https://addons.mozilla.org/en-US/firefox/addon/3497) Can anyone speak good english give me a recommendation with a short explanation why. I need only one EN-dict. Thanks

This review is for a previous version of the add-on (1.19). 

not good, not good at all. Rated 1 out of 5 stars

I like Firefox, but since an internal update to 2.0.0.16 I've had a shit-load of problems with all my add-ons (they seem to have disappeared and the most useful one is refusinjg to come back. the En-GB ilnine spelling checker add on is the most useful and while it claims to be all versions compatible, I've continually been unable to get it back.

Come on guys, SORT IT OUT!!!!

This review is for a previous version of the add-on (1.19). 

1.19 with firefox 3.0.1 Rated 5 out of 5 stars

I was getting the message that my already installed 1.19 was incompatible with Firefox 3.0.1.
Even though if you check the "See All Versions" page, it does say 1.19 is compatible with 3.0.1!?!

However, I uninstalled and reinstalled and it seems to be fine now.

Perhaps the 1.19 has now been given a quick tweak. Time to call it 1.19.1?

This review is for a previous version of the add-on (1.19). 

Rated 4 out of 5 stars

I managed to get this to work. Install the dictionary, copy both the files it installs ('en-GB.dic' and 'en-GB.aff') to Program Files\Mozilla Firefox 3\dictionaries. Next, type about:config into your firefox browser. Search for all instances of "en-US" (or just "en-" if you want to find other dictionaries). Change all the instances of "en-US" to "en-GB" and hey presto! proper spelling is yours...

This review is for a previous version of the add-on (1.19). 

Rated 1 out of 5 stars

Does not work with Firefox 3.0.1 :-(

This review is for a previous version of the add-on (1.19). 

Rated 1 out of 5 stars

DOWNLOAD SHOULD BE SIGNED!!

This review is for a previous version of the add-on (1.19). 

Rated 4 out of 5 stars

Great tool.

Unfortuantely it's not compatible with Firefox 3.0.1 (as I descovered after updating FF).

This review is for a previous version of the add-on (1.19). 

Excellent Rated 5 out of 5 stars

ok, a few thoughts

0. Why not use an exe? Then we could install by double clicking the file...

1. It is unsigned, but that seems very common these days.

2. I had no problem installing, but I'm on Vista32sp1 and use Firefox.

3. The tests I performed, using "colour", "surprise" (and "suprise"), "cheque", "favourite", "neighbour" (and "nieghbour"), "sceptred", all worked. It even corrected the US spellings eg "sceptered" became "sceptred". It did not recognise "empanel", however and suggested the US "impanel". Minor stuff, though.

Possibly the problems other users are having come from their using other OSs or other browsers, or perhaps even from their having a corrupt version of TB.

If you can get this to install, I highly recommend it. Mozilla, unlike M$, actually care enough about their international customers to give them a dictionary, within a free app, for their own language/usage. Won't see me migrating back to LiveMail/WinMail/IE now...

This review is for a previous version of the add-on (1.19). 

Rated 1 out of 5 stars

Not compatiable with 2.0.0.15

This review is for a previous version of the add-on (1.19). 

How to Install Rated 5 out of 5 stars

This download is a stuffed file so I unstuffed it, selected the app icon> right click > show package contents > MacOS > dictionaries and drop them in there, alongside the two you have already.

This review is for a previous version of the add-on (1.19). 

Rated 1 out of 5 stars

Downloaded, tried to install, found it wasn't compatible, updated to Thunderbird 2.0.0.14, tried to install again, still not compatible.

Come on people, get it sorted. This dictionary is nearly two years old!

This review is for a previous version of the add-on (1.19). 

Rated 5 out of 5 stars

An honourable add-on to one of my favourite programmes.

This review is for a previous version of the add-on (1.19). 

Rated 5 out of 5 stars

I great help to all users of this programme.

This review is for a previous version of the add-on (1.19). 

Rated 5 out of 5 stars

I love this i have trubble speling some words while overs i cunnt spel at all so this cums in handy

This review is for a previous version of the add-on (1.19). 

HELP Rated 1 out of 5 stars

I cannot get this to load on firefox 3, says not compatible. Please someone help?

This review is for a previous version of the add-on (1.19). 

Best i'v seen. Rated 5 out of 5 stars

the best and useful thing i've seen.

This review is for a previous version of the add-on (1.19). 

what's wonderful thing! Rated 5 out of 5 stars

the applications you provide are useful and ahead of time.i thank you very much.

This review is for a previous version of the add-on (1.19). 

Rated 5 out of 5 stars

yes! no more spelling mistakes from me;) brilliant

This review is for a previous version of the add-on (1.19).