Very Useful Rated 5 out of 5 stars

I have recently rebuilt this .xpi addon to make compatible with the new firefox versions, with lots of great features, like no wait time to install addons, new inprovements to addons panel and make compatible context option to older addons.