¿Upgrade to 3.5? Rated 5 out of 5 stars

Hiya! I upgraded to Firefox 3.5 just to find out that Latin Dictionary is not working (yet). Are you going to fix that? I hope so. Gratias tibi in advance!

This review is for a previous version of the add-on (0.37.20080612).