Rated 5 out of 5 stars

I've had BetterGaia installed for awhile, but I'm a little down because it doesn't work with Firefox 4.0 beta 9 or 10. So I can't upgrade to that. Do you think you could update it so it will work? Thanks if you do!

This review is for a previous version of the add-on (0.3.4.3).