About me

Developer Information
Name sin1ster
User since February 19, 2013
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

RoboForm Lite Password Manager

Rated 5 out of 5 stars

The .js zemu error can be eliminated by downgrading to FF14

This review is for a previous version of the add-on (3.4.7).