Ted Clayton

About me

Developer Information
Name Ted Clayton
User since January 2, 2010
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

Web Paint

Graphics-editing & creation should be part of the browser! Rated 5 out of 5 stars

Web Paint is a new addon, by a first-time addon author. Addons that enable drawing in the browser are not common, or well-developed, yet the category could be very useful & diverse (not to mention, fun!).

Though this addon is in early development and lacks many obvious features and capabilities, it is a good effort in an area that needs attention. Therefore, I'm giving it 5 stars.

The drawing-functions respond slowly; there is clearly some hefty overhead. Text-drawing is in only one large size (and font); this limitation will get awkward fairly quick. The edit-tools pop-up UI is in the screen (work-area); as more options & controls are added, the growing popup will become more intrusive (another UI-solution might be needed, eventually). But overall it's a good find; I look forward to using it, and hopefully seeing continued development.

This review is for a previous version of the add-on (1.0.7.1-signed). 

Tab Catalog

Rated 5 out of 5 stars

Firefox 4! :)

Stack Style Tabs

Rated 5 out of 5 stars

Firefox 4! :)

DMOZ Bookmarks

Rated 5 out of 5 stars

Stills sounds like an excellent asset ... would look good on my new ff 4.0!

But, both "Continue to Download" links produce the following Firefox error:

"The add-on from mozilla.org could not be installed because it does not match the add-on Firefox expected."

I bookmarked it, and will check back. :)

This review is for a previous version of the add-on (0.110123.17.1-signed).  This user has a previous review of this add-on.

Vertical Tabs

Rated 5 out of 5 stars

Just Awesome.

I have All in One Sidebar and Vertical Tabs, side by side, minimizing, no problems.

And the infernal Tab Bar (horizontal) is gone.

Sounds like good "goals".

Thanks! :)

This review is for a previous version of the add-on (0.7.4.1-signed).  This user has 2 previous reviews of this add-on.

Vertical Tabs

Rated 5 out of 5 stars

Just Awesome.

I have All in One Sidebar and Vertical Tabs, side by side, minimizing, no problems.

And the infernal Tab Bar (horizontal) is gone.

Sounds like good "goals".

Thanks! :)

This review is for a previous version of the add-on (0.7.4.1-signed).  This user has other reviews of this add-on.

Vertical Tabs

Rated 5 out of 5 stars

Just Awesome.

I have All in One Sidebar and Vertical Tabs, side by side, minimizing, no problems.

And the infernal Tab Bar (horizontal) is gone.

Sounds like good "goals".

Thanks! :)

This review is for a previous version of the add-on (0.7.4.1-signed). 

ClassicFox

Rated 5 out of 5 stars

Sounds neat! I'm a Classic fan. :)

And no - I too did not know I had this imperfection. Now I will lying awake at night... ;)

... Because, the plugin would not work for me. ;(

Attempting to Install, Firefox reports:

"ClassicFox 2.1.1 could not be installed because it is not compatible with Firefox 3.6.15."

I see this tempting item has not been update in going on 3 years. I have considered learning to do FF extensions: if this is a modest code - and it sounds like it may be - perhaps it is a good one to cut my teeth on.

Bitdefender QuickScan

Rated 5 out of 5 stars

I 'opted in' to the BitDefender offer, while upgrading ... maybe while taking off FF 4 and then 'catching up' again to v3.6.15. I have BitDefender as both a "plugin" and as an "extension".

It strips the "Back - Forward" button and the "Location Bar" from the Navigation Bar. At some point while deactivating several dozen plugins and restarting FF, one by one, the entire Main Menu grayed out.

Sure, this is a 'come on' from the BitDefender people, but it's still 'a good thing'. They just need to be more careful, do a large-population Beta run.

I.e., I do not use the Tab Bar at all, and have Compact Classic Theme ... and other "idiosyncracies" which may 'set me up' for adverse interactions with BitDefender's plugin ... but all my special settings are totally legit, and BD should 'live gracefully' with them.

I will keep the BitDefender plugin for now - deactivated - and will be watching closely for an update from them

This review is for a previous version of the add-on (0.9.9.77.1-signed). 

DMOZ Bookmarks

Rated 5 out of 5 stars

Sounds like it would be of great interest, but it wouldn't install for me (v3.6.13):

"Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/addon/6231/contribute/roadblock/?src=oftenusedwith&version=0.110123.17

because: Invalid file hash (possible download corruption)
-261"

This review is for a previous version of the add-on (0.110123.17.1-signed). 

TagSieve

Rated 5 out of 5 stars

Ah ... good news to see Hark update this tool for more-robust bookmark management. Best wishes on the v4 release & future enhancements!

This review is for a previous version of the add-on (4.2.8). 

OpenBook

Rated 5 out of 5 stars

I would dearly love to have this plugin, but attempting to Download/Install generates the error-message:

"OpenBook 2.0.1.1 could not be installed because it is not compatible with Firefox 3.6.13."

I am perplexed & vexed by the Paleolithic design elements of Firefox' bookmark (so-called) Dialogs. Won't move. Can't resize. Waayyy to small.

Strange. Fortunately, I accept 80% solutions ... and FF is at least 97%. ;)

This user has a previous review of this add-on.

Cite This!

Rated 5 out of 5 stars

The "Continue to Download" buttons do not.

Instead, they initiate "Download", and then generate errors in the Firefox plugin facility.

There is something wrong with the "Continue to Download" button, and we cannot get this plugin.

Sounds cool. I want my citations local - not tied to some website 'out there'.

Will check back!

This review is for a previous version of the add-on (0.19). 

OpenBook

Rated 5 out of 5 stars

I save lots of bookmarks, in extensive hierarchies. Enlarging the Dialog, and gaining better control of the Tree, are minor Holy Grails for me - for real! :)

But, when installing this plugin, I receive:

"Incompatible Extension
OpenBook 2.0.1.1 could not be installed because it is not compatible with Firefox 3.6.13."

I will save the link to plugin-page (thru my undersized & clunky Dialog) and check back often!

Broadband Speed Test and Diagnostics

Rated 5 out of 5 stars

A useful & easy-to-use plugin. A 'keeper'.
Yeah, it 'phones home'. Is it going to check the connection by staring at it's navel?
I have extreme end-of-the-line 'copper DSL', guaranteed 256K *max* - no typo. It has consistently tested in the 240s, and does so with DSL-SpeedTest. Upload test 304Kb.

Quick. Polite. Clean. Recommended - 5.