Flash Player Plugin has been blocked for your protection.

Why was it blocked?
Old versions of the Flash Player plugin are targeted by known security vulnerabilities, and cause frequent Firefox crashes. We strongly recommend all users to visit the Flash Player homepage to download and install the latest available version of this plugin.

This is not an ordinary block. It's just an upgrade notification that will be shown to all users who have these old versions installed, asking them to download the latest version. If they choose to ignore the notification, the plugin will continue to work normally.
Who is affected?
All Firefox users who have a version of the Flash Player Plugin older than 10.2.159.1.
What does this mean?

The problematic add-on or plugin will be automatically disabled and no longer usable.

When Mozilla becomes aware of add-ons, plugins, or other third-party software that seriously compromises Firefox security, stability, or performance and meets certain criteria, the software may be blocked from general use. For more information, please read this support article.