Great, but needs update Rated 4 out of 5 stars

Works great, but the maximum version currently supported is limited to 7.*, so it needs to be updated for Firefox 8.

This review is for a previous version of the add-on (1.6.4.1-signed).