Please help Rated 5 out of 5 stars

After the last update of Firefox this supplement does not work. Please! Make sure that this supplement to work with version 4 of Firefox. PLEASE! Take care! If you do not have this supplement will need to use another browser. / Sorry for no exact translation - used a computer translator