Rated 1 out of 5 stars

Incompatible with Firefox 15 (Nightlies) which is a shame.