Please Make it 3.6.13 compatible! Rated 2 out of 5 stars

Doesn't work with the newest firefox! 3.6.13 I hear great things about the software, and I'd really like to be able to use it!

This review is for a previous version of the add-on (0.2.1).