zblack not compat with firefox 3.6 Rated 1 out of 5 stars

zblack doesn't work anymore with Firefox 3.6. So many things don't work now in 3.6! Very frustrated with firefox 3.6!