Roll Back for 16.0.2 Compatibility Rated 5 out of 5 stars

The reviewer linking you to the 1.0.7 version of YTSR got it right - works perfectly.