Not Work On FF 9 Rated 1 out of 5 stars

Damn! Not work for my FF 9!!

This review is for a previous version of the add-on (3.0.4.1-signed).