works great with ff 39.0 Rated 5 out of 5 stars

Thank you! It works perfect with my firefox 39.0.

This review is for a previous version of the add-on (38.0-signed).