Won't work with Firefox 9.0.1? Rated 3 out of 5 stars

I was looking forwards to using this, but I can't get it to work with Firefox 9.0.1.

This review is for a previous version of the add-on (1.5.1).