Rated 4 out of 5 stars

If you change the install.rdf file's line to something like this:
<em:maxVersion>9.*</em:maxVersion>

and then restart firefox, this plugin still works fine.