Rated 1 out of 5 stars

>"Why don't you click on "Ignore Version Check"

Because it doesn't help?

FF 3.6.6 will NOT activate this add-on. I need to debug my feeds and I miss this a lot.