Rated 5 out of 5 stars

Please update it for Firefox 5.0
I would like to use it

Rated 5 out of 5 stars

i wish i could use it D: you need to update it for the new firefox