Please support Firefox 4.0 Rated 5 out of 5 stars

Wonderful extension, but please update for Firefox 4.0!

This review is for a previous version of the add-on (3.7.8).