Still works! Rated 5 out of 5 stars

Incredibly, this still works with FF4 if you force compatibility!!!

Rated 5 out of 5 stars

The 0.993 version works with FF 3.5 if you force it compatible.