This add-on shouldn't be in here Rated 1 out of 5 stars

It's only compatible with TB1/FF1. Sorry I have to give one star to post this comment.