Attention FF3 Users Rated 5 out of 5 stars

While waiting for update, you can temporarily allow this theme (or all incompatible add-ons) to function as follows:

* Type about:config into Firefox's address bar and click the "I'll be careful, I promise!" button.
* Right-click anywhere. Choose New>Boolean. Make the name of your new config value extensions.checkCompatibility and set it to false.
* Make another new boolean pair called extensions.checkUpdateSecurity and set the value to false.
* Restart Firefox.

(Courtesy: http://lifehacker.com/355973/make-your-extensions-work-with-the-firefox-3-beta)

This review is for a previous version of the add-on (2.6).