Rated 5 out of 5 stars

great theme, love its clear design, thanks! NO Firefox 4 support - but, in fact, it can work fine with FF4 beta, one needs just to modify <em:maxVersion> in install.rdf ... I tried it and works absolutely fine with FF4. 1 min change ....