Rated 1 out of 5 stars

Its written that it will work Firefox 4.0 - 7.* but if you want to install Firefox tells that it is not compatible to 6.0.2 :-(
@Atlassian: It works if I install it from addons.mozilla.org, and even if I download it and install it manual.
But the Problem shows up if I try to edit an office Document in Confluence 4.0 and I dont have the plug-in installed.
Today I have found the following bug report: https://jira.atlassian.com/browse/OFFCONN-48 which is unresolved.

This review is for a previous version of the add-on (1.0.5.1-signed). 

Are you installing it from addons.mozilla.org from inside your browser or are you downloading it then installing it manually?