Rated 5 out of 5 stars

This extension continues to work without any new problems on Firefox 3.5, so for those of you who want to use it without running an older version of Firefox, just grab MR Tools and use it to force compatibility.