Rated 5 out of 5 stars

Essential add-on. To temporarly override "preferences bug" in FF 2.0, downgrade to version 3.5.1

This review is for a previous version of the add-on (4.0.2).