disfunction with new Firefox Rated 5 out of 5 stars

Doesn't work with 3.6.11 M. Firefox version.

This review is for a previous version of the add-on (3.3).