Rated 5 out of 5 stars

Hey! update to FF 3.5 please!! I've been using your theme for about a year and now it's not compatible. I don't think any theme could fill this void :)

This review is for a previous version of the add-on (3.10).