Rated 4 out of 5 stars

Please update to Firefox 3.5.x
Firefox 3.5.xでも動作するようにアップデートをお願いします。

This review is for a previous version of the add-on (2.2.2008050101).