Indispensable for web development Rated 5 out of 5 stars

If you go to the url params homepage site there's a newer version, 2.2.2, that works in Firefox 3.6 for me. (I downloaded it, then double-clicked the download and chose to run Firefox.exe against it.)

This is indispensable if you're doing web development - a great and simple tool! Pair this with the Tamper Data add-on and you've got lots of power to view and edit your http params.

This review is for a previous version of the add-on (2.2.2).