Love 1.5.1 dearly; others, not so much Rated 4 out of 5 stars

I had to roll back to 1.5.1 because newer versions no longer work the way I'm used to. I gather from the changelog that the new behavior I've been experiencing is intentional and not a bug; but I don't care to get used to it. I simply want the following functionality, which 1.5.1 gives me, without fail, on every URL:

Starting with this example: http://www.example.com/abc/xyz/index.html

Clicking Uppity once, I want to see: http://www.example.com/abc/xyz/

Clicking again, I want: http://www.example.com/abc/

Again, I want: http://www.example.com/

Again: http://example.com/

Newer versions appear to be essentially broken from my perspective, since they often refuse to go up beyond a certain number of levels (I gather this is intentional, for some reason, which, again, I'm not interested in discovering).

Anyway, I love Uppity, use it constantly, and simply cannot be without it. But I'll be sticking with 1.5.1 (I hope it continues to work with future versions of FF; I'm currently on 3.0.10).

This review is for a previous version of the add-on (1.5.3). 

This is a bug

Sorry for your problems. This is not intended, and is a bug. Certain recent versions (since 1.5.1) had a bug that kept them from going up twice. Check the latest versions, especially 1.5.5 which I just released (and will not be public on AMO until the review completes).