Not Working with Firefox 6.0. Rated 1 out of 5 stars

This addon does not work with Firefox 6.0, have to upgrade.