update firefox 4 Rated 5 out of 5 stars

firefox 4 needed!!! plese

Rated 4 out of 5 stars

update version 3.4 firefox, please!!!!!!!!

This review is for a previous version of the add-on (0.1.5.4).