Rated 3 out of 5 stars

This needs to have max version set to 3.6.*, in order to make it compatible with the latest Firefox version...

This review is for a previous version of the add-on (1.7.2).