Firefox 3.x compatibility Rated 3 out of 5 stars

The theme is available for Ubuntu users from the distribution package manager, and installed by default AFAIK.

Please update for Firefox 3.0 and 3.5 in order to allow other to use it.