FF 45.0.2 disables the addon Rated 3 out of 5 stars

The new version of Firefox introduced a new verification system that automatically disable unconfirmed addons, including this one.

This is no longer needed. The functionality has been implemented directly in Sumo/Firefox a few versions ago. Versions of Firefox that require add on signatures do not need this addon.

FF 45.0.2 tells me Troubleshooter is disabled Rated 3 out of 5 stars

When will a new version be available, or is it not necessary anymore?

This is no longer needed. The functionality has been implemented directly in Sumo/Firefox a few versions ago. Versions of Firefox that require add on signatures do not need this addon.

Rated 5 out of 5 stars

This add-on is EXTREMELY helpful for us at the support team because it helps us to have all of the required information in front of us. This helps us to improve your support experience and solve problems faster.

This add-on should be installed in all versions of Firefox automatically.

I'm glad to hear this is working well! There is some work to get this kind of information collection built into the browser, and that work is being covered in Bug 732527 [0] and related. Hopefully this will make it into a near future version of Firefox.

[0]: https://bugzilla.mozilla.org/show_bug.cgi?id=732527